2FA not working for users

Hi,

2FA is not working for users. E-mail and using an authentication app keeps failing when submitting the token code. The error that shows is: Code validation failure

The strange thing is that it works fine when logging in as admin!

Does anyone know what might be the issue? Seems very strange that it works for logging in as admin but not as a user?

Thanks for your help.

Can anyone help with this?

Hello John,

Apology for the delay in getting back to you.

Please let us know the below details.

  1. Are you using mixed characters (uppercase and lowercase letters) in the username while login?
  2. Web-browser you are using.
  3. Screenshot of the error you are getting.
  4. FileCloud version you are using.

Sorted. It was the usernames having uppercase in.

I’m I able to link to AD with the Community Edition? When I try to add a new user it is greyed out?

Hello @John

Apology for the delay in getting back to you.

Please update us with a screenshot of the issue you are facing so that we can have a better look at this.
Also, please include a full window screenshot of the admin dashboard as well.

Hello @John

Thank you for the update.

We have opened an internal ticket for our Developers to further investigate this issue. The ticket id is CL-7760. You can use this as a reference in future communication.

Is there an update? I would like to get this resolved.

Hi @John

AD user authentication option is available with the latest version (20.3.0.13059).

Thank you. Will try to test it.

Does not work. It will allow me to use AD but when adding a user I get a message saying that the user does not exist or there is no e-mail address attached. I have added an e-mail address to the AD account but still shows the same message.

In Settings, it does show that AD is connecting ok under the test.

Hi @John

Please share with us the full screenshot of the AD settings in the FileCloud Admin Portal. Also, the screenshot of this user property from AD (General and Account tab’s).

Will do once I can get access again. Currently locked out (look at other ticket)

1 Like

@John

Can you please do the following
–> checkout the option Users have same UP account suffixes
–> add to the field AD Base DN as DC=Home,DC=local

After saving these changes, click on AD Test and then click on Validate AD settings option. Share a screenshot of the same.

Please check if this works for you.

That worked!

Thank you so much!