File Download Limit 2GB?

Filecloud ver 21.1
I am sharing files of over 1GB, and when I my client tries to download, the download halts at 500mb and restarts. i tried it myself and It does the same thing. Cannot download files over 500mb. Is there a limitation to Filecloud??

@Robin

How are you downloading the files? Are you using any client applications or user portal?
Any error message while downloading the file? A screenshot is appreciated.

im downloading from browser. using Opera or Chrome is the same. Click download on a Zip file, and it downloads at servers maximum rate. Downloading at 8Mb/s. very fast. As soon as the download gets to 500, it cuts off and restarts. anything under 500mb works fine. Not using any client. Just the web portal. Tried at multiple computers and locations.

After many tests, this is what i am coming up with.
Any file that is under 2GB is size, will download just fine. Any file over 2GB will start downloading and after it has downloaded around 400mb, it will reset and restart download in a loop.

all this after updating to 21.1
Any ideas ???
ver 21.1.

I made a video of the issue. File over 2GB is resetting.

After some research, apparently, it’s a browser issue. Has anyone else have this problem? I think one must use a download manager for files larger then 2GB. Any ideas?

Hello @Robin

Thank you for the update.

Please provide the below details.

  1. Screenshot of the page Admin Portal > Settings > Storage > My Files tab.
  2. FileCloud Log from the server after setting the LOG level to DEV. You can do this by navigating to Admin Portal > Settings > Server > Log Level.

Once the log level is set to DEV, try to reproduce the issue and send the logs. You can find the location of the logs as follows.

Windows: \xampp\htdocs\scratch\logs\log_YYYY-MM-DD.txt
Example: c:\xampp\htdocs\scratch\logs\log_2020-06-27.txt (Select the latest date)
Linux: /var/www/scratch/logs/log_YYYY-MM-DD.txt (in Ubuntu 14.04 and later /var/www/html/scratch/logs/log_YYYY_MM_DD.txt)

@anand.prabhu
This is where the error is. from the LOG File

*** ERROR: ERROR: Maximum execution time of 60 seconds exceeded on line 217 in file C:\xampp\htdocs\src\Application\ResponseEmitter.php.
2021-05-19 15:31:23.223510 ERROR: CLFC-00004 ERROR | 2021-05-19 15:31:23 | 1 | Maximum execution time of 60 seconds exceeded | C:\xampp\htdocs\src\Application\ResponseEmitter.php:217
2021-05-19 15:31:23.233277 ERROR: SHUTDOWNERROR: Maximum execution time of 60 seconds exceeded on line 217 in file C:\xampp\htdocs\src\Application\ResponseEmitter.php.

So after some tests. Here is what I came up with.
With version 20.3, i can download any filesize without any issues. But since version 21.1 is better designed, I WANT version 21.1 to work. lol

When I download a file smaller then 2GB, I downloads without issue, even if it takes longer then 60 seconds. If I try to download a file larger then 2GB, then i get this error:
indent preformatted text by 4 spaces

2021-May-19 05:17 PM
Critical
ERROR | 2021-05-19 16:17:36 | 1 | Maximum execution time of 60 seconds exceeded | C:\xampp\htdocs\src\Application\ResponseEmitter.php:217

@Robin

Please share the full logs file as requested, so that our Developers can investigate further.
Also, please include a screenshot of the page Admin Portal > Settings > Storage > My Files tab.

I modfied a setting in the .htaccess File

RewriteRule ^(.*)/?$ public/index.php [L]

php_value memory_limit 500M
php_value post_max_size 500M
php_value upload_max_filesize 500M
php_value max_execution_time 300  <<< this was 60, I put 300
php_value max_input_time 300

php_value max_execution_time was set to 60. I set it to 300, and now i can download large files.

@Robin

Thank you for the update.
We will forward this to our Development Team for further checks.

@Robin

We have got an update from the Development Team on this.

Changing the execution time to a higher value may not fix the issue permanently.

To understand and troubleshoot the issue, the Team is requesting the FileCloud logs in DEV mode.

Please update us with the logs to assist you better on this.

Any update on getting this fixed. We have the same issue

Hello @Robin and @esoto

Our Development Team is checking on this issue; we will get back to you as soon as we have an update on this.

Hello @Robin

Our Development Team has provided a patch for the issue you are facing. Please download the zipped patch file from the below URL.

https://zerg.codelathe.com/url/cxgcu3mwjitvndaa

Please follow the below steps to apply the patch.

  1. Navigate to the location " C:\xampp\htdocs\src\Application\Controller ".
  2. Rename the file " FileController.php " present in this location to " FileController.php.original."
  3. Copy paste the extracted patch file to the same location.
  4. Revert all the changes you made to the .htaccess file.
  5. Test the download operation again and update us on how it goes.

Yes. I put back the original values in the .htaccess file , replaced the file with the one you sent, rebooted the server completely and NOw it WORKS GOOD. :grinning:

Thank you so Much.

Hello @Robin

We are happy to hear that the patch worked.

I am seeing a similar but not identical issue with downloads. In this case I am seeing downloads “freeze” rather than restart. This is version 21.1.2.15173. The user states:

“I am seeing an issue with downloading a number of files as zip. It gets stuck at 58.28MB” and he provides a screenshot showing this.

I asked for more details and he provided the following:

“It is a strange one, I have a folder under my account called <sanitised>. I can download the whole folder from My Files, as well as going into the folder and downloading about 10 files in one go, but if I am in the folder I can’t download all the files and folders in one go.
Not a show stopper as there appears to be a work around, but weird behaviour.”

Is this the same issue, a browser issue or something new?

Cheers

Michael Lightfoot
Delivery Engineer
Sliced Tech
Canberra, Australia

Hello Michael,

Can you update us with a couple of screenshots of the issue and provide the server logs in DEV mode?