Invalid License Host error

Hello Team,

today i have purchased community edition license and tried to install it.
i constantly get error that says"Invalid License Host"

Current Version: 20.1.1.7769, attached license file

Please advise.

Best Regards.

@Greg

Welcome to the FileCloud Community Edition Forum.

Can you please check if you are installing the license using/from the URL for which you have bought the license for.

For example: If the license is for abc.com then you need to log in as abc.com/ui/admin/index.html and then try installing the license.

Please check from your side and if you are still facing the issue, provide us with the screenshot of the error including the URL.

Hello Somitha,

my server URL is the same as the host in license.xml.
attaching screenshot of error and license file.

Many thanks and
Best Regards.

filecloud

Hello Somitha,

i found a way to install license. I have entered my Win server for FileCloud, modified hosts file to resolve my external URL with internal IP address, and then uploaded license. That did worked… very odd…

Best Regards.

@Greg

Thank you for the update.

Great to hear your issue has been solved.

Same issue here: “Invalid License Host”, after having tried the benefits of a Trial license for a few days.
Before, with the identical file, identical server and identical config, the license file was accepted.
Could it be that having installed a Trial license somehow is the problem?

@Arcesilaus

Usually, the " Invalid License Host " error happens when the FileCloud URL and license URL are different.
Please check whether you are accessing the admin portal with the URL which you bought the trial license for.
If the issue happens for the same URL, please update us with full windows screenshots of

  1. The error you are getting (please include the URL).
  2. FileCloud Admin Portal > Settings > Server tab

Hello All,

i found a root cause for at my case. i use VMware UAG (unified access gateway 3.9) as reverse proxy for FileCloud server. when accessing my server directly from internet or from local network all works just fine, server recognizes my license. Once traffic goes through UAG, i get error. It seems, that when doing reverse proxy somethings get messed.

Still looking how to fix it.

Best Regards.

You’re right: that is indeed causing the problem.
I was convinced that all was still the same on the FileCloud machine and I was right, but that was not the only machine in the setup: once I had set the ‘pass host header’ setting in my Sophos XG reverse proxy, the license file was properly loaded again.
Thank you!

@Arcesilaus We are happy to hear that the issue has been resolved.

@Greg When you using the reverse proxy are you using a different URL to access the FileCloud site?

Hello Anand, no, i have configured internal and external FQDN to be same.
in addition, license file assigned to external FQDN ( files.domain.com)

Best Regards.

Same here, using identical FQDN (and split-dns). Works just fine now.

@Arcesilaus, Hi, does it works fine with UAG as reverse proxy? what is the configuration?

Hi, I am not using an UAG, but Sophos XG (formerly Cyberroam):

Capture

@Arcesilaus, unfortunately, UAG don’t have those options available. it’s less configurable…