Is it okay to upgrade apt packages on the server?

Is it okay to maintain up-to-date packages on a server hosting FileCloud? Is there a risk that doing so could break FileCloud?

On my Ubuntu server running this command

app list --upgradable

shows this output:

certbot/xenial 0.31.0-2~deb10u1+ubuntu16.04.1+certbot+3 all [upgradable from: 0.27.0-1~ubuntu16.04.1]
python-acme/xenial 0.31.0-2+ubuntu16.04.6+certbot+2 all [upgradable from: 0.31.0-2~ubuntu16.04.1]
python-augeas/xenial 0.5.0-1+ubuntu16.04.1+certbot+1 all [upgradable from: 0.5.0-1]
python-certbot-apache/xenial 0.31.0-1+ubuntu16.04.1+certbot+1 all [upgradable from: 0.23.0-1~ubuntu16.04.1]
python-cffi-backend/xenial 1.10.0-0.1+ubuntu16.04.1+certbot+1 amd64 [upgradable from: 1.5.2-1ubuntu1]
python-chardet/xenial 3.0.4-1+ubuntu16.04.1+certbot+2 all [upgradable from: 2.3.0-2]
python-configargparse/xenial 0.11.0-1+certbot~xenial+1 all [upgradable from: 0.10.0-2]
python-configobj/xenial 5.0.6-2+ubuntu16.04.1+certbot+1 all [upgradable from: 5.0.6-2]
python-cryptography/xenial 1.9-1+ubuntu16.04.1+certbot+2 amd64 [upgradable from: 1.2.3-1ubuntu0.3]
python-idna/xenial 2.5-1+ubuntu16.04.1+certbot+1 all [upgradable from: 2.0-3]
python-ipaddress/xenial 1.0.17-1+certbot~xenial+1 all [upgradable from: 1.0.16-1]
python-josepy/xenial 1.1.0-2+ubuntu16.04.1+certbot+1 all [upgradable from: 1.1.0-1~ubuntu16.04.1]
python-ndg-httpsclient/xenial 0.4.2-1+certbot~xenial+1 all [upgradable from: 0.4.0-3]
python-openssl/xenial 17.3.0-1~0+ubuntu16.04.1+certbot+1 all [upgradable from: 0.15.1-2ubuntu0.2]
python-parsedatetime/xenial 2.4-3+ubuntu16.04.1+certbot+3 all [upgradable from: 1.4-1]
python-pkg-resources/xenial 33.1.1-1+certbot~xenial+1 all [upgradable from: 20.7.0-1]
python-pyasn1/xenial 0.1.9-2+certbot~xenial+1 all [upgradable from: 0.1.9-1]
python-requests/xenial 2.18.1-1+ubuntu16.04.1+certbot+1 all [upgradable from: 2.9.1-3ubuntu0.1]
python-requests-toolbelt/xenial 0.8.0-1+ubuntu16.04.1+certbot+1 all [upgradable from: 0.6.0-2]
python-rfc3339/xenial 1.0-4+certbot~xenial+1 all [upgradable from: 1.0-4]
python-setuptools/xenial 33.1.1-1+certbot~xenial+1 all [upgradable from: 20.7.0-1]
python-six/xenial 1.11.0-1+ubuntu16.04.1+certbot+1 all [upgradable from: 1.10.0-3]
python-urllib3/xenial 1.21.1-1+ubuntu16.04.1+certbot+1 all [upgradable from: 1.13.1-2ubuntu0.16.04.4]
python-zope.component/xenial 4.3.0-1+ubuntu16.04.1+certbot+3 all [upgradable from: 4.2.2-1]
python-zope.hookable/xenial 4.0.4-4+ubuntu16.04.1+certbot+1 amd64 [upgradable from: 4.0.4-4build2]
python-zope.interface/xenial 4.3.2-1+ubuntu16.04.1+certbot+1 amd64 [upgradable from: 4.1.3-1build1]
python3-cffi-backend/xenial 1.10.0-0.1+ubuntu16.04.1+certbot+1 amd64 [upgradable from: 1.5.2-1ubuntu1]
python3-chardet/xenial 3.0.4-1+ubuntu16.04.1+certbot+2 all [upgradable from: 2.3.0-2]
python3-configobj/xenial 5.0.6-2+ubuntu16.04.1+certbot+1 all [upgradable from: 5.0.6-2]
python3-cryptography/xenial 1.9-1+ubuntu16.04.1+certbot+2 amd64 [upgradable from: 1.2.3-1ubuntu0.3]
python3-idna/xenial 2.5-1+ubuntu16.04.1+certbot+1 all [upgradable from: 2.0-3]
python3-pkg-resources/xenial 33.1.1-1+certbot~xenial+1 all [upgradable from: 20.7.0-1]
python3-pyasn1/xenial 0.1.9-2+certbot~xenial+1 all [upgradable from: 0.1.9-1]
python3-requests/xenial 2.18.1-1+ubuntu16.04.1+certbot+1 all [upgradable from: 2.9.1-3ubuntu0.1]
python3-six/xenial 1.11.0-1+ubuntu16.04.1+certbot+1 all [upgradable from: 1.10.0-3]
python3-urllib3/xenial 1.21.1-1+ubuntu16.04.1+certbot+1 all [upgradable from: 1.13.1-2ubuntu0.16.04.4]
tzdata/xenial-updates,xenial-security 2021a-0ubuntu0.16.04 all [upgradable from: 2020f-0ubuntu0.16.04]

The command is

apt list --upgradable

Otherwise my question remains and it should be easy to answer after 5 days. Thank you.

@Unimatrix

Apologies for the late reply.

You can use the command and upgrade the packages.

2 Likes