MESSAGE QUEUE SERVICE not Starting

After Installing the Latest update 21.1, I noticed that the Message Queue service is not starting. It gives an error: Cannot start service : fcorchestrator
In the Windows services, the fcorchestrator service is Paused and I cannot start. I Uninstalled the service using the nssm.exe in command line, and then reinstalled, rebooted many times the server, but still wont Start. Any help would be appreciated.
Thanks
Rob

I tried doing another upgrade over the upgrade 21.1 that was already done to see maybe it would solve the issues, but it didn’t. It says that it was completed successfully but still cant run the servers as pictured above.

UPDATE:
I reinstalled the services that where not starting using Command
C:\xampp\nssm remove

All the bottom services are now on except the Message Queue service > FCORCHESTRATOR

I uninstalled it, and reinstalled, but does not want to Start.

I recopied my old folder, version 20.3, before the upgrade, and all Services work great. So I can say, that the problem is with the programming in version 21.1

@Robin

can you try to start the FileCloud control panel as Administrator and try to install the message queue service?

Also, can you share the install check details here?

Hello @Robin

Thank you for the update.
We will check this further with the Development Team and get back to you.

In the meantime, please let us know whether you have any antivirus/malware scanners installed on the server.

I dont have any antivirus installed, except for the basic windows defender.

@Robin

Please update us with the below details.

  1. Full window screenshot of the registry location.

Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\fcorchestrator\Parameters

  1. Try to start the Message Queue service from the command line and let us know whether you get any errors (screenshot).
  1. Start the command prompt
  1. Navigate to C:\xampp\htdocs\src\Scripts
  1. Run the command
    C:\xampp\nodejs\node.exe fcorchestrator.js

12m 1s

Well, I think we found the problem. I am Running Windows Server 2011 (Windows server 2008 r2), and apparently Nodejs is not supported until Windows Server 2012 r2. I will try to skip the test and see if it starts.

finally found how to fix the problem.
Yeayy

  1. Go to control panel -> System -> Advanced System Settings then environment variables.

  2. under system variables i created a new one with NODE_SKIP_PLATFORM_CHECK and set its value to 1 .

  3. Go to Folder C:\xampp\nodejs

  4. Right click Properties on Node.js > Compatibility, and put a checkmark on " run this as administrator"

  5. Restart complete Machine.

Hello @Robin

Thank you for sharing the fix.