Server URL (https) is invalid

Hi all,

I generated a self-signed certificate (both key and crt files only, no CA chain file generated) on server console and updated the configuration files by following the link https://www.getfilecloud.com/supportdocs/display/cloud/Install+an+SSL+certificate+on+Ubuntu

After restarting the apache server and trying to open the server URL starting with “https://”, the “server URL is invalid” error showed on screen.

I would like to know the following:-

  1. Can the self-signed certificate be used to your filecloud application to provide https service ?

Regards,

Hi @arthurchan

Can you please share the screenshot of the share and server URL to assist you better with this?

Hi,

Below please find the screen shots for your follow-up.

Regards,

@arthurchan

Please add the below entry in the " /etc/hosts " in the server and check whether you can change the server URL to https://filecloud.erb.org

127.0.0.1 filecloud.erb.org

Hi all,

The entry “127.0.0.1 filecloud.erb.org” had been added to /etc/hosts before your reply but the error could still not be fixed.

We can change the Server URL to https://filecloud.erb.org in Settings -> Server -> Server URL of admin web page but can not save this change as the error “Server URL is invalid” showed on screen when clicking the “Check URL” button.

By the way, we set an private IP (not a public IP) and installed a self-signed certificate (generated with openssl) to this server for testing in our intranet, must we set a public IP and installed ssl certificate from a public trusted CA to this server in order to solve “Server URL is invalid” problem ?

Regards,

Hello @arthurchan

Please share with us the FileCloud Log from the server after setting the LOG level to DEV. You can do this by navigating to Admin Portal > Settings > Server > Log Level.

Once the log level is set to DEV, try to reproduce the issue and send the logs. You can find the location of the logs as follows.

Linux: /var/www/scratch/logs/log_YYYY-MM-DD.txt (in Ubuntu 14.04 and later /var/www/html/scratch/logs/log_YYYY_MM_DD.txt)
Example: /var/www/html/scratch/logs/log_2020-06-27.txt (Select the latest date)

This problem has been solved when installing an SSL certificate by trusted CA instead of self-signed one.

Regards,