Server URL not accessible

Hi,

Every time I type in my external URL address in the “Server URL” section I keep getting this error message even though the URL is correct and working and has a SSL:

“Server URL is not accessible. This might affect some server functionality like background processing.”

How can I fix this?

Thanks,

Hello John,

Please check whether the FileCloud site URL is resolving properly to the server IP address.
The URL should resolve properly in the server.

Nope, still not working. It won’t even resolve to the default local IP address too.

Hi @John

Apology for the delay in getting back to you.

Please let us know the below details.

  1. FileCloud site URL you are using.
  2. FileCloud server OS (Windows/Linux).
  3. Full window screenshot of the page Admin Portal > Settings > Server tab.

https://remote2.waller.uk
Windows Server 2019

Hello @John

Apologies for the delay in getting back to you.

Please add a hosts file entry like below in the FileCloud server and check whether the issue still presents. Also, if you are using the HTTPS in the FileCloud URL, please make sure the certificates are installed on the server.

127.0.0.1 remote2.waller.uk

That worked. Thank you.

Hi @John

Happy to hear that the issue has been resolved.

@Graxo

Please let us know whether you are trying to add the server URL with “HTTPS” from the Admin Portal? If yes, is it possible to add the relevant SSL certificate and Key to the FileCloud Serer and check?

Yes, im adding it with https. im running FileCloud in a docker, how do i add the ssl to the docker config?

I stopped using the docker version and started is to a “normal” Ubuntu installation, added the certificate to Apache, changed the /etc/hosts 127.0.0.1 to my domain name.
Then i all worked fine. On to the next issue :slight_smile:

Hello @Graxo

Apologies for the delay in getting back to you.

We are happy to hear that the URL validation working fine with the normal Ubuntu installation.