Setup Cron Job in Linux – are the instructions up to date?

There seem to be a number of out-of-date instructions for setting up a cron job in my instance of Centos 7.6 and the current version of FileCloud: 20.2.3.12065.

The extension locations in the instructions don’t exist:

cannot access /etc/php/7.0/apache2/conf.d: No such file or directory
cannot access /etc/php/7.0/cli/conf.d: No such file or directory
cannot access /etc/php/7.0/cli/: No such file or directory

PHP extensions are located in /etc/php.d. The extensions for ioncube (20ioncube.ini) and mongo (mongodb.ini) are already there.

As instructed I added “extension=mongo.so” to php.ini but this resulted in an error: “PHP Startup: Unable to load dynamic library ‘mongo.so’” I have learned that the file “mongo.so” has been replaced by “mongodb.so”. There was a different problem when I added “extension=mongodb.so” to php.ini: “PHP Warning: Module already loaded in Unknown on line 0”. I ended up removing the extension declaration.

Another problem is that the location given for the cron script: “/var/www/core/framework/cron.php” doesn’t exist. I see something similar, so I’ve tried using it for the cron job: “/var/www/html/src/Core/Infrastructure/Cron/CronManager.php”.

The cron job fails now with this message (received in root mail):

Subject: Cron apache@filecloud php /var/www/html/src/Core/Infrastructure/Cron/CronManager.php
Content-Type: text/plain; charset=UTF-8
Auto-Submitted: auto-generated
Precedence: bulk
X-Cron-Env: <XDG_SESSION_ID=141>
X-Cron-Env: <XDG_RUNTIME_DIR=/run/user/48>
X-Cron-Env: <LANG=en_US.UTF-8>
X-Cron-Env: <SHELL=/bin/sh>
X-Cron-Env: <HOME=/usr/share/httpd>
X-Cron-Env: <PATH=/usr/bin:/bin>
X-Cron-Env: <LOGNAME=apache>
X-Cron-Env: <USER=apache>

Status: R
Forbidden

I’m hoping someone can straighten me out and help me get the FileCloud cron job to work. Thank you.

@Unimatrix

Apologies for the late reply we will check this on our end and get back to you.

I have a similar question as with my other open post. Would it be okay to use FileCloud in production without cron jobs? Any ideas on how I can get cron jobs to work by hook or by crook (on Centos 7.6)?

@Unimatrix

Cron will be installed in your server during the installation for FileCloud server, you can verify this from Admin portal >> Checks >> Last cron job was run at, if you are getting any error in this check, please let us know.

The cron job was not installed during installation and it’s not running. The warning in System Checks is “Cron job or task scheduler has not been setup”.

I’m repeating the issue here: the published instructions for creating a cron job mentioned a script file “cron.php” but the containing folder, and a file of that name, do not exist in my server. I guessed that the “cronManager.php” script was a new script file to substitute, but in my first post I shared the error message when I tried to point the cron process to that one. It said “Status: R Forbidden”

It seems that this should be resolved if I knew which is the correct PHP script to use? Would it be useful for me to share a file and folder listing of my FileCloud installation?

In the upgrade to 20.2.4.12080, cron was set up correctly and automatically. The location of the PHP script in

crontab -u apache -e

is now

/var/www/html/src/Scripts/cron.php

This is different than what it was in the documentation I read a few weeks ago when I posted this topic.

Hi @Unimatrix

Apology for the delay in getting back to you.

Usually, the cron automatically set up during the FileCloud installation.

Can you please run the Checks from the Admin Portal and look for the result " Last Cron Job was run ". It will show the last time the cron ran.

Sorry, I may not have been clear about the current status. After the upgrade to 20.2.4.12080 the issue fixed itself, or rather, the upgrade fixed it. Cron jobs are running now.

Hello @Unimatrix

Thank you for the update.
We are happy to hear that the issue has been resolved now.