Unable to connect via FileCloud Drive

Hello! I have our filecloud community edition up and running for a couple of weeks and it is working absolutely wonderful. However, I am unable to connect to our server via the FileCloud Drive app. Any help would be appreciated!

Our Filecloud is hosted in Windows. I keep getting error regarding certificate verify fail. I have included a screenshot.

Thanks!

@evolution54

Thanks for posting.

It seems that you have installed SSL certificate. Can you please double check if you have added the Chain certificate also. As these certificates are important for all the FileCloud Apps.

You need to make sure that “SSLCertificateChainFile” is not commented out in the Apache SSL config. You can find more details in below documentations.

==

https://www.getfilecloud.com/supportdocs/display/cloud/Manually+Install+SSL+Certificates+for+FileCloud+on+Windows

https://www.getfilecloud.com/supportdocs/display/cloud/Install+an+SSL+certificate+on+Ubuntu

==

Hi somitha,

Thank you for response! Unfortunately, I followed directions but still couldn’t get it to work. Here is more details:

I am using a wildcard certificate from GoDaddy. FileCloud is installed on a Windows Server 2016 virtual machine.

Upon installing FileCloud, I used the FileCloud Control Panel GUI to install the certificate, private key and intermediate files. If I look inside the ssl.crt and ssl.key folder, I see the files have been imported. The only other modification I can think of that I made was disabling port 80/http access so that the server can only be accessed via https on port 443. No other port is enabled to this server externally.

I then followed your instructions on manually importing the certificate for Windows via the link you sent. Because the server.crt and server.key files were already imported, I skipped that part. I was however not able to find the intermediate file in either of those two folders.

I first uncommented out the line: SSLCertificateChainFile.

Next I renamed the GoDaddy intermediate certificate to server-ca.crt and copied it to the ssl.crt folder.

Next I replaced the ServerName field in the same file with my domain name: “files.domain.com”.

I restarted the server multiple times but I am still getting the same error on multiple machines with FileCloud Drive installed. Is there anything else I am overlooking?!

Thanks.

Hi Somitha,

You can disregard this request. I got it to finally work. Turns out there was something weird going on with the GoDaddy certificate/chain. On the PCs, I see that the website was secured correct and it showed the ssl chain correctly. However, when I went to a SSL checking website, it found that the chain was actually broken. I have verified and reverified that I did everything correctly as we use that same wildcard certificate on many other websites.

I proceeded to generate a Let’s Encrypt certificate instead to test and voila, everything now connects without issues, both the FileCloud Drive in Windows and on Android.

Thank you!

@evolution54

Sorry for the late reply.

Glad to hear that your issue is resolved. Please get back to us if you need any assistance.