Upgrade and can't login

Just upgraded to the new version and now I am unable to login in Admin. I keep getting this error message and it’s the same for my other site installs:

Incorrect username or password. Error code: CLFC-00161

Hello @John

Please update us with the below details so that we can have a better look at this.

  1. Full window screenshot of the error.
  2. Are you using an email address or username for admin login?
  3. Any mixed characters (upper + lower case) or special characters in the username?

Username: Administrator

Hi @John

From the screenshot of the error, it looks like the username or password is incorrect. If you haven’t customized the admin username, please try with the “admin” as the username?

You can also reset the admin password from the FileCloud control panel. Please refer to the session " Reset Admin Password using the FileCloud Control Panel " in the below URL.

https://www.getfilecloud.com/supportdocs/display/cloud/Resetting+Admin+Password

If you are in a Linux environment, please run the below command.

filecloudcp -r

Done that and says password reset ok but it still says the same when tryng to login. This is the same for another site too,

I managed 3 sites. 1 of them uses the username admin and that works fine and the other 2 both use Administrator for admin and both fail to login. Even after resetting the admin password from the Concole.

Hi @John

Are you able to provide us the latest MongoDB dump from your end so that we can try to recreate this issue from our end?

How do I do that and send it secure?

What do I need to do? Thanks.

We are about to enter full lockdown. Can someone please help as I need to get access to the sites ASAP.

I’m now no longer able to login on the the site that was working using “admin”. I can’t login in to any of the sites that I managed.

Please add this line to C:\xampp\htdocs\config\cloudconfig.php and restart the Apache service:
define(“TONIDOCLOUD_ADMIN_USER”, “administrator”);
There is a bug in the current version, login to FileCloud Admin portal is not possible if admin name contains uppercase letters.
Setting this parameter will change the admin name to administrator.

I now get this when trying to access the site.

An internal error has occurred while processing your request.

Sadly it does not work. Adding that line kills the websites and removing it brings it back up. I’m back where I was before by removing that line out as I have a school using one of them for remote access :frowning:

Is there a new update that I can use? I’m sure i’m not the only person with this problem?
Is there anything else I can try?

@John

Can you please share a screenshot of the error you are getting when you changed the config line.

Also, please provide a screenshot of the developer console window, when you get the error.

developer console window?

Hi, I could really do with a proper fix as all the schools that I support are now working from home from tomorrow and I really need to have access to the admin section. I recommended this software to the schools and they don’t currently know that I can’t login.

@John

I tried to access the links (admin portal and user portal) from our side and it seems to be loaded without error. Are you having any antivirus or firewall installed in your system or in front of the server or any VPN services?

Can you please try accessing from a different browser or system and try logging into your account.

I had to take the line out of the cloudconfig.php file so that I can log in and access files. That is why you can see it. I have added the line back in and restarted Apache.